Investigating Queue Cluster Network Spike

Incident Report for Pencil

Resolved

This incident has been resolved.
Posted May 08, 2026 - 19:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 08, 2026 - 18:31 UTC

Investigating

We have identified a network traffic spike issue affecting the queue cluster. Our engineering team is actively investigating the root cause and working on mitigation steps to stabilize the environment.

Some production workloads may experience intermittent delays during this period. We will continue to provide updates as we learn more.

Thank you for your patience.
Posted May 08, 2026 - 18:17 UTC
This incident affected: pro.trypencil.com.