3P Agent Tool Connectivity Issues

Incident Report for Pencil

Resolved

This incident has been resolved.
Posted May 26, 2026 - 09:44 UTC

Investigating

Some third-party connections are temporarily disrupted. We are actively working on a resolution.
Posted May 25, 2026 - 11:01 UTC
This incident affected: app.trypencil.com, pro.trypencil.com, and cn.trypencil.com.