Elevated Error Rates for Nano Banana Model

Incident Report for Pencil

Resolved

This incident has been resolved.
Posted Mar 07, 2026 - 03:24 UTC

Investigating

We are currently experiencing elevated error rates with the Nano Banana model due to resource exhaustion issues affecting Google AI infrastructure.

This is resulting in intermittent request failures and degraded performance for some AI-powered features that rely on this model.

Our team is actively working in close coordination with the Google team to investigate and resolve the issue as quickly as possible. The issue appears to be related to upstream capacity constraints.

We will continue to provide updates as we receive more information.
Posted Mar 06, 2026 - 11:36 UTC
This incident affected: app.trypencil.com and pro.trypencil.com.