⚠️ Partial Service Degradation – Cloudflare R2

Incident Report for Pencil

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 11:46 UTC

Identified

Affected Services: Object storage access via Cloudflare R2
We are currently experiencing increased error rates while accessing Cloudflare R2. This is due to an ongoing Cloudflare incident impacting R2 availability.
Some users may encounter : Failed or slow asset loads, Intermittent errors for services dependent on R2-backed storage

Cloudflare is actively investigating the issue. We are closely monitoring the situation and will share updates as more information becomes available.

External Incident Reference:
https://www.cloudflarestatus.com/incidents/53q8j8wnctyc
Posted Feb 16, 2026 - 10:58 UTC
This incident affected: app.trypencil.com, pro.trypencil.com, and Cloudflare R2.