Resource Exhaustion Errors on Google AI Models

Incident Report for Pencil

Resolved

This incident has been resolved.
Posted Mar 29, 2026 - 16:47 UTC

Investigating

We are currently experiencing increased error rates due to resource exhaustion impacting the Google AI models used in our platform.

As a result, some AI-powered features may show intermittent failures or degraded performance.

Our team is actively working with the Google team to investigate and resolve the issue at the earliest. This seems to be related to upstream capacity limitations.

We will continue to share updates as more information becomes available.
Posted Mar 18, 2026 - 11:05 UTC
This incident affected: app.trypencil.com and pro.trypencil.com.